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Bonus activity 
Project: Creating your own rocket animation using 
Adobe Animate (Flash) 

Glossary 
animation The process of creating an illusion of motion by the rapid display of a 
sequence of images that differ slightly from each other 
cel A single frame of an animation 
keyframes Show the start and end of a simple animation sequence 
persistence of vision A characteristic of the human eye and brain that interprets 
rapid changes in images, resulting in the optical illusion of continuous motion 
tweening Frames between keyframes that ‘fill in’ or complete intermediate 
movements in an animation 

In Digital Technologies 7 & 8 our digital design focused on non-moving (static) projects.  
In Digital Technologies 9 & 10 we work with media involving movement: digital animation 
and video. 

You will learn many skills here: motion and shape tweening, drawing skills, nested 
timelines, orienting to paths, adding audio and more. 

THE TASK 
You will create an animation of a rocket to use later as part of a programming project. 

Knowledge probe: Animation 
Animation relies on a property of the brain and eye known as persistence of vision. It can be 
defined as the process of creating the illusion of movement by the rapid display of a sequence 
of images, which each differ by a small amount. 

Animations can be created using flip-books, using mechanical devices, by stop-motion 
(photographing an object in multiple poses) or by using many hand drawn frames known as 
cels. 

Keyframes show the start and end of a simple animation sequence. Frames between 
keyframes in traditional animation complete intermediate movements. This process is known 
as tweening (short for ‘in betweening’). In Figure 1 Animate keyframes are shown as black 
diamonds and tweening is shown as a blue shaded bar. 
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Figure 1 Keyframes in Adobe Animate are shown as black diamonds and the tweening is shown as a 
blue shaded bar in the timeline 
 

Today computers automate the process of tweening once keyframes have been created. 
Movement along a path, rotation, colour change, fading and scaling can all be tweened 
automatically. 

Skill builder: Types of tweening in Adobe Animate 
Note: Only one object at a time can be tweened per layer using Animate. If you want to 
tween several objects simultaneously, each needs to live on its own. 
Motion tweening: A motion tween is created automatically in Animate by creating a new 
symbol (make sure you convert the shape to a symbol) and then right-clicking on it and 
choosing Insert Motion Tween. This creates a motion path between that newly created 
keyframe and the next keyframe. The tween is shown in the timeline in blue. There can be no 
more than one motion-tweened symbol per layer. 

Shape tweening (see Figure 2): Shape tweens are morphs or distortions of vector graphics. 
Two different shapes (non-symbols and not grouped) in two keyframes can be tweened. The 
shape tween will perform whatever calculations are needed to change the first shape into the 
second automatically (shown in timeline in green). 
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Figure 2 Shape (and colour!) tweening between two keyframes each containing a shape – ellipse to 
pentagon. The timeline shows in green with an arrow. 

Classic tweening: A motion tween creates keyframes automatically but a classic tween 
instead requires you to first manually create keyframes and then connect them by tweening. 

So in summary, a shape tween is a transformation tween, while a motion tween affects 
position and rotation. 

Nested timelines: Animated objects often have their own internal animation. For example, a 
butterfly moving left to right across the stage will have an animation of its wings flapping 
while it moves along a path. This is achieved with a second timeline nested inside the main 
one. These kinds of animations are self-contained inside a movie clip symbol. Nested 
timelines are a great way to achieve complicated animations in Adobe Animate. Note that 
nested timelines will loop unless stopped using a script. 

Animating a rocket launch 
In this task you will learn the basics both of drawing and of animation using Adobe Animate 
CC by animating a simple rocket launched towards a rotating planet. 

We have chosen to animate a rocket launch, because the project in Chapter 9 of the 
textbook uses this animation in a number guessing game where a player’s guesses trigger an 
appropriate rocket animation. 



© David Grover & Seven Vinton 2017 4 Bonus activity DT 9 & 10 

 
Figure 3 Our rocket animation uses both motion and shape tweens. 

Defining 
1 Draw a storyboard to illustrate your animation and label the features you will animate on 

your storyboard. 
In the following we will: 
• add a backdrop of a night sky star scene 
• draw a launch gantry 
• draw a rocket 
• animate rotating planet (motion tween) 
• animate path of the rocket (motion tween) and animate shrinking rocket (as it travels 

further away) 
• animate flames from the base of the rocket (shape tween) 
• animate the star scene by having it rotate (motion tween) 
• provide audio of a rocket launch. 

2 Now is the time to acquire the following assets: 
• an mp3 launch audio file (available online from NASA) 
• a suitable space star image 
• a suitable .png image of a planet. Open it in Photoshop to edit and save it with 

transparent background. 

3 Import all assets to the Library using File > Import to Library… 
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Designing 
Set up new document 
1 Open a new Adobe Animate document: New > New document. 

2 Set dimensions to 550 px × 400 px. 

3 Set Type to ActionScript 3.0 (this is needed as in a later project we add coding using 
Actionscript 3 rather than HTML5 in order to easily use an input field). See Figure 4. 

 

 
Figure 4 Starting a new animation in Adobe Animate 
 
Background star scene 
1 In Timeline rename ‘Layer 1’ to ‘Background’. 

2 Select frame 100 and right-click > Insert frame. 

3 Select frame 1 of this layer and drag your space star image from Library onto the stage. 
Resize and position but leave some overlapping the edge of the stage to allow us to 
animate it later as a slow ‘night sky’ rotation. 

4 Use Modify > Convert to bitmap and Modify > Break apart to delete areas not required. 
See Figure 5. Lock this layer using the lock icon in timeline. 
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Figure 5 Background night sky scene in locked Background layer, sized to stage. 
 
Gantry 
1 Create new layer and rename it ‘gantry’. 

2 Draw the gantry as shown in Figure 6 using Tools > Brush. Remember that brushes paint 
with a Fill not a Stroke colour. 

3 Open Properties panel to set brush size. Hold Shift to draw straight lines. Lock this layer 
using the lock icon in timeline. 

 

 
Figure 6 Draw the rocket launcher gantry in a new layer using the brush tool. 
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Planet 
1 Create a new layer and rename it ‘planet’. 

2 Select frame 1 of this layer and drag your planet image from Library onto the stage. 
Resize and position. See Figure 7. 

3 This image must be converted in Animate to symbol to make it possible to later animate 
its spin. Select planet and Modify > Convert to Symbol…  Name this symbol 
‘planet_spin’. 

 
Rocket 
1 Create another layer for the rocket and name it ‘rocket’. 

2 Draw the base of rocket using a rectangle with a linear gradient fill using two colours 
(see Figure 7) and add a nose cone using the Polystar tool (choose Properties > Options 
and set sides to ‘3’ before drawing). 

3 Use Modify > Free Transform to rotate and move your triangular cone to the top of 
rocket base. 

4 Group both objects and Modify > Convert to Symbol. Name this symbol ‘rocket’. 
 

 
Figure 7 The three layers and their objects: star background, gantry, planet and rocket. 
 
  



© David Grover & Seven Vinton 2017 8 Bonus activity DT 9 & 10 

Implementing 
Create nested planet spin animation 
1 Select frame 1 of your main timeline’s planet layer. 

2 Double-click on the image of the planet symbol. The main timeline will disappear and a 
new nested timeline will be created separately for this planet symbol. Name the only 
layer now showing ‘planet_spin’. 

3 Go to frame 50 in this new timeline and right-click > Insert Frame. 

4 Right-click on any frame and Add Motion Tween. The frames will turn blue to indicate a 
motion tween has been created. 

5 Select any frame along this motion tween and open the Properties panel. See Figure 8. 
Set Rotation to ‘1’ and select CW (clockwise) for Direction. This will create a clockwise 
rotation. 

 

 
Figure 8 Set rotation for planet spin on nested timeline 
 

6 Control > Play only controls the main timeline and so nested timelines (as with the 
‘planet_spin’ here) will not play for now. Instead test using Control > Test. 

 
Create rocket trajectory using a motion tween 
1 Create a motion tween for the rocket trajectory: Return to the main timeline by clicking 

Scene 1 or the back arrow at the top of your animation window. 

2 Click in frame 1 and right-click to Add Motion Tween. The frames will turn blue to 
indicate a motion tween has been created. 

3 Select frame 100 in the rocket layer and drag the rocket over the planet. 

4 Adjust the trajectory curve. (Hide background layer to make this easier to see.) 

5 Select rocket symbol and shrink the rocket as shown in Figure 9 using Modify > Free 
Transform. 

6 Drag the timeline control to about halfway along the path and the rocket will move. 
However, it is oriented wrongly as shown in Figure 7. Select the motion tween dotted 
path, open Properties and select Orient to path checkbox (see Figure 10). 

 



© David Grover & Seven Vinton 2017 9 Bonus activity DT 9 & 10 

 
Figure 9 The rocket trajectory before orientation to path 
 

 
Figure 10 Select the motion tween dotted path, open Properties and select Orient to path checkbox 
 

7 Control > Test. 
 
Create rocket flames using shape tweening 
1 Double-click the rocket to create a nested timeline for the rocket’s flames. 

2 Add three new layers in this nested timeline called ‘flame1’, ‘flame2’ and ‘flame3’. 

3 Select the circle tool with a red fill and no stroke and make sure object drawing is turned 
on in the tool palette. 

4 At the base of the rocket, draw a red circle in frame 1 of ‘flame1’ layer, and similarly an 
orange overlapping circle in ‘flame2’ and a yellow overlapping circle in ‘flame3’. See 
Figure 11. 

5 Deselect all flame drawings. Bring the selection pointer tool near the edges of the flames 
and reshape them as shown in Figure 9. 

6 Shift-select frame 16 in all these three layers and insert a keyframe. 

7 Reshape all flames in the same way. 
 



© David Grover & Seven Vinton 2017 10 Bonus activity DT 9 & 10 

    
Figure 11 Creating the shaped rocket flames 
 

8 Place the cursor around frame 5 and right-click > Create Shape Tween for each. 

9 Shift-select all frames in all three layers, and while holding Alt/Option, slide the frames 
to fill frames 17–32. They should remain selected. Right-click and Reverse Frames. This 
will result in the last frames of each shape tween being identical to the first, which 
eliminates jumpiness. 

10 Extend the rocket timeline if necessary to frame 32. See Figure 12. 

11 Select all frames in the animation and Control > Test. 
 

 
Figure 12 Finished separate nested timeline for the rocket and flames. Return to main timeline by 
clicking on Scene 1 at top of stage. 
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Animate rotating background star scene 
1 Select the star scene on the stage and Modify > Convert to symbol as a movieclip symbol. 

2 Add a keyframe to the last frame in the star scene layer on the main timeline and Create 
Motion Tween between first and last keyframes. 

3 Select any frame in this motion tween and open the Properties panel. Set Rotate to 
0 times and just +20 for the degrees of rotation. See Figure 13. 

 

 
Figure 13 Setting background star scene rotation to 20 degrees 
 

4 Control > Test. If the background is not big enough then select it using Modify > Free 
Transform to enlarge it. 

 
Add audio 
1 Return to the main timeline by clicking on Scene 1 above your animation. Add audio to 

your animation by dragging your mp3 file from the library to your stage. 

2 Choose Properties and set Sync to Stream, Repeat to 0, and Fade Out. See final version 
in Figure 14. 

3 Choose Control > Test. 
 

 
Figure 14 Final rocket launch animation showing audio layer 
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Note: A finished working file and .swf file are available in the online resources as 
‘rocket_launch_animation_finish’. 
 

Adding your own creative touch! 
This is your chance to use the skills you have now developed to either create a new animation 
or to add features to this one. 

Some ideas: 
• More planets and twinkling stars! 
• Add smoke to the flames. 
• Add a comet streaking through the sky. 
• Have the gantry fall away on launch. 
• Create a better rocket. 
•  (Advanced) At present the planet spins clockwise and looks unnatural, make it spin 

left to right using motion tweening of an aerial image of a planet’s surface masked by 
a circle. Masking a layer is turned on by right-clicking the layer that contains the 
mask shape and selecting Mask. The layer below it will then be masked by whatever 
shape is used. 

• (Advanced) Create rocket spin. See if you can create the illusion of the rocket 
spinning in flight by having two colours of a gradient slowly reverse positions over 
the span of a tween. Create a nested tween by double-clicking on the rocket, then 
break the symbol apart to allow shape tweening on the nested movieclip timeline. 
Save your animation file as you may need it later for a programming project. 

Evaluating 
1 What did you learn from this project? 

 

 

 

 

 

2 What improvements would you suggest? 


